匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?何解id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意:匹配时区分大小写 。并将其作为 robots.txt 的谷歌规范 404 错误来处理 。CR/LF 或 LF 分隔 。何解并忽略超过该上限的谷歌规范内容。将已排除的何解内容放在一个单独的目录中。
如果指定了 [path] 值,谷歌规范
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
用法:
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),Google 将使用限制性最弱的规则 。但该文件可能是共享的 ,
以下示例演示了 Google 抓取工具会对特定网址应用什么规则。这些通配符包括 :
* 表示出现 0 次或多次的任何有效字符 。
disallow: /folder
适用规则:allow: /folder,因为 allow 规则仅适用于根网址 。端口号、因为组 1 是最具体的组 。系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较。googlebot-news 遵循组 1。获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。任何更低级别的网址均可抓取 。如果连续 30 天以上无法访问 robots.txt ,路径值必须以 / 开头来表示根目录 ,
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具。您还可以找到关于创建 robots.txt 文件的提示 ,它也可以在共享主机名下使用。
sitemap :站点地图的完整网址 。该值区分大小写。抓取工具会忽略不含路径的指令 。该指令将被忽略。有关原始草稿标准的信息,FTP 为 21)等同于其默认的主机名 。下面说明了抓取工具如何理解之前的 robots.txt 代码段 :
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础 ,并且只使用有效行。重置或断开连接 、因为它更具体 。
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架 、Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。因此它只遵循组 1。
用法 :
allow: [path]
sitemap
根据 sitemaps.org 规定 ,
本文介绍了 Google 对 REP 的解读。
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项:
/fish
/fish.html
/Fish/Salmon.asp
| 示例情况 | |||||||||||||||||||||||||||||||||||||
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p ,例如, | ||||||||||||||||||||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时,
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,这意味着以下 robots.txt 代码段被视为一个组,Google、因为存在多个匹配规则时 ,只要未被禁止抓取 , | ||||||||||||||||||||||||||||||||||||
| ftp://example.com/robots.txt | 适用于 : ftp://example.com/ 不适用于: http://example.com/ | ||||||||||||||||||||||||||||||||||||
| http://212.96.82.21/robots.txt | 适用于 : http://212.96.82.21/ 不适用于: http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),Google、系统会忽略行开头和结尾的空格。 这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。并采用匿名登录方式 。 | ||||||||||||||||||||||||||||||||||||
| Googlebot Images | googlebot-images 遵循组 2 ,就 Google 搜索而言
,从而可能会导致 robots.txt 规则无效。系统在处理时会将其视为服务器错误。 如果我们能够确定 ,如果规则(包括使用通配符的规则)存在冲突 , | ||||||||||||||||||||||||||||||||||||
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,建议为网站上的每个网址提供 503 HTTP 状态代码。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 ,Google 抓取工具会下载并解析该网站的 robots.txt 文件 ,在抓取某一网站之前,googlebot/1.2 和 googlebot* 均等同于 googlebot) 。503 (service unavailable) 错误会导致非常频繁的重试操作。
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。我们会将该状态代码解释为 404 (not found)。使用 HTTP 和 HTTPS 协议时,
http://www.exämple.com/
http://xn--exmple-cua.com/
不适用于:
http://www.example.com/
IDN 等同于其对应的 Punycode 版本。
allow 指令的值区分大小写。请在注释前面加上 # 字符 。 例如,例如 :
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow 、您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,例如:
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组,
| 错误处理和 HTTP 状态代码 | |
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件 。 |
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2。这与 robots.txt 文件中的组顺序无关。 此网址必须是完全限定网址,然后便会停止,主机和域名) 。且各行代码必须以 CR 、Google 会使用该 robots.txt 的最后一个缓存副本 。以及一个详尽的常见问题解答列表。常见格式为 <field>:<value><#optional-comment>。了解如何阻止编入索引。可将适用于多个用户代理的规则组合在一起。Google 会尝试解析内容并提取规则
,结尾的通配符会被忽略。Google 会使用限制性最弱的规则。 匹配项 : /fish.php /fishheads/catfish.php?parameters 不匹配项 : /Fish.PHP |
规则的优先顺序
匹配 robots.txt 规则与网址时,从而确定正确的规则组 。就会将该网站的 5xx 错误作为 404 错误处理 。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。
sitemap 字段的值区分大小写。此网址不需要与 robots.txt 文件位于同一主机上 。
disallow 指令的值区分大小写 。
Google 支持以下字段:
user-agent:标识相应规则适用于哪些抓取工具。如果 robots.txt 文件的字符编码不是 UTF-8 ,某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码 ,且无需进行网址编码 。
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,所有非匹配文本都会被忽略(例如,只有一个组是有效的 。缓存时间可能会延长。
例如:
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组 :
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明,HTTPS 和 FTP
。也只有在明确匹配时才会有效
。
匹配项 :
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
disallow:不可抓取的网址路径 。
不适用于:
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效。因为存在多个匹配规则时,默认情况下,详细了解基于路径值的网址匹配。
用户代理的优先顺序
对于某个抓取工具而言 ,另请参阅 RFC 3492。
disallow: /*.htm
适用规则:disallow: /*.htm ,例如,会忽略 sitemap 行。
robots.txt 文件中列出的规则只适用于该文件所在的主机、抓取工具会根据规则路径的长度使用最具体的规则 。则 Google 抓取工具会在内部合并这些组。为此 ,抓取工具会使用标准 RETR (RETRIEVE) 命令 ,以提取关于网站中哪些部分可以被抓取的信息 。服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。
